Friday, October 21, 2016

Windows Server 2016 Hyper V requirements

Windows Server 2016 Hyper V has introduced great features (for more info, please checkout the official article What's new in Hyper-V on Windows Server 2016 ), but before jumping in and formatting the disk with previous version of Windows Server operating system with Hyper V installed, please make sure that your hardware has the needed requirements. The easiest way is to run systeminfo.exe from command prompt or Powershell, and checkout the Hyper V requirements part from the command output (for example: this is the output from supported hardware):


In my case, I was having one test box HP DL380 G5 with Windows Server 2012 Hyper V role installed, and the output from systeminfo.exe for Hyper V part, looked like this:


For Windows Server 2016 Hyper V role, Second Level Address Translation (SLAT) is requirement, instead recommendation as it was for Windows Server 2012 Hyper V. So, if you don't check these requirements and you try to install Windows Server 2016 Hyper V role, you might experience the following error message:


Conclusion: some old hardware boxes might not be able to see the "light" of the new Microsoft Windows Server 2016 with Hyper V role installed.

No comments:

Post a Comment